공식사이트 문서 Yarn Installation를 보고 따라하면 대부분의 경우 Install하는데 문제가 없지만

Linux에서 Install 중 Error 발생하는 경우

아래와 같은 에러가 발생 할 수 있다. 혹은 다른 에러도 발생할 수 있음.

E: Unable to locate package yarn

cmdtest 에러가 뜨는 경우가 있는데 우분투 17.04이상에서 자동으로 설치된 cmdtest가 yarn을 다른 yarn으로 인식해서 발생하는 오류. 아래 명령어로 cmdtest를 삭제하고 설치해준다.

sudo apt remove cmdtest

에러를 해결해도 설치가 안되는 경우가 있다 yarn자체를 찾지 못한다. yarnpkg가 필요 하다.

1. yarnpkg를 global로 설치.

npm을 사용할 것이므로 node.js가 설치되어 있어야 합니다.

Prerequisite: node.js

sudo npm install -g yarnpkg

2. curl로 패키지에 yarn을 추가.

curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list

3. Update & Install

sudo apt-get update && sudo apt-get install yarn

4. Version Check

yarn --version

immer는 객체 비구조화 문법(Object Destructuring)을 사용하면 동작하지 않는다.

## [immer](https://github.com/immerjs/immer)는 객체 비구조화 문법(Object Destructuring)을 사용하면 동작하지 않는다.아래는 redux에서 reducer쪽 immutable state를 immer...… Continue reading

2019 카카오 FE(Front-end) Meetup

Published on September 16, 2019

2019 카카오 개발자 컨퍼런스

Published on September 11, 2019